API documentation - Sinon.JS - v2.3.8

This page contains the entire Sinon.JS API documentation along with brief introductions to the concepts Sinon implements.

Migration guides

Compatibility

ES5.1

Sinon v2.3.8 is written as ES5.1 and requires no transpiler or polyfills to run in the runtimes listed below.

Supported runtimes

v2.3.8 has been verified in these runtimes:

  • Firefox 45
  • Chrome 48
  • Internet Explorer 11
  • Edge 14
  • Safari 9
  • Node 4

There should not be any issues with using Sinon v2.3.8 in newer versions of the same runtimes.

If you need to support very old runtimes that have incomplete support for ES5.1 you might get away with using loading es5-shim in your test environment. If that fails, we recommend getting a legacy releases of Sinon.

Stuck?

Please ask questions on the mailing list if you’re stuck.

Contribute

We really appreciate suggestions to improve the documentation so Sinon.JS can be easy to work with. Get in touch!