API documentation - Sinon.JS - v11.1.0

This page contains the entire Sinon.JS API documentation along with brief introductions to the concepts Sinon implements.

Migration guides

Compatibility and supported runtimes

As of Sinon 10 we stopped maintaining compatibility with legacy browsers. Instead, we focus on compatibility with evergreen browsers, Node.js LTS versions and recent Safari versions. The most up-to-date reference on which runtimes and browsers we support can be found by looking at our compatibility docs.

If you need to support old runtimes you can try Sinon 9.

Stuck?

Please ask questions on Stack Overflow if you’re stuck.

Contribute

We really appreciate suggestions to improve the documentation so Sinon.JS can be easier to work with. Get in touch!